How to Display Status in a Status Chart (GS 7.3)

You can build one or more status charts to monitor and debug program operations after you download your program to the PLC.

If you have the PLC in RUN mode, your program is executing on a continuous scan basis. You can turn Chart Status on to update status chart values on a continuous basis. As an alternative to turning on Chart Status, you can use the Single Read function to gather a single "snapshot" of status chart values.

While you are viewing a status chart, you can also put the PLC in STOP mode and use the First Scan or Multiple Scans feature to monitor program operations for a limited number of scans.

Tip:

Remember that you cannot edit your chart when you have turned on Chart Status!

Turn off Chart Status to edit your chart.

This topic discusses the following subjects:

Example of a Status Chart

Opening a Status Chart versus Turning On Chart Status

Using Multiple Status Charts

Building a Chart

Editing Shortcuts

Data Formats

Single Read versus Continuous Chart Status

Writing versus Forcing Values

Using the Debug Functions in Status Chart

Example of a Status Chart

Back to Top

Opening a status chart is not the same thing as turning one on. You can open a chart to edit or examine it, but unless you issue a Single Read command (from the Debug menu or toolbar) or turn on Chart Status (from the Debug menu or toolbar) no status information is displayed in the Current Value column.

When you use the Single Read feature (available only when Chart Status is turned off) to examine a status chart, the current values from the PLC are collected and displayed in the Current Value column, but they are not updated as the PLC executes your program.

When you turn on Chart Status (from the Debug menu bar or toolbar), the current values from the PLC are collected on a continuous loop basis. When changes are received from the PLC, the Current Value column is updated.

You can use the New Value column to assign (write or force) a value that you specify. You can force the current value from the Current Value, Format, or Address column.

Opening a Status Chart versus Turning On Chart Status

(Back to Top)

Open a chart to view or edit the contents of the chart. Turn the chart on to gather status information.

Use one of the following methods to open a status chart:

·Click on the Status Chart button on the Navigation Bar.

·Select the View>Status Chart menu command.

·Open the Status Chart Folder in the Instruction Tree , then double click on a Chart icon.

·If you have more than one Status Chart in the Project, use the Chart tabs at the bottom of the Status Chart window to move between charts.

Use one of the following methods to turn on a status chart:

·To gather status chart information on a continuous basis, turn on Chart Status: use the menu command Debug>Chart Status or use the Chart Status toolbar button.

·To obtain a single "snapshot" of values, use the Single Read function: use the menu command Debug>Single Read or use the Single Read toolbar button. (If you have already turned on Chart Status, however, the Single Read function is disabled.)

Tips:

·Opening a chart does not mean you are viewing status. You must turn the chart on in order to gather status information.

·Turning the chart on serves no purpose if the chart is empty: you must first "build" your chart by placing program values (operands) in the Address column and selecting a data type for each one in the Format column.

Using Multiple Status Charts

(Back to Top)

There are several ways to create additional Status Charts:

·From the Instruction Tree, right-click on the Status Chart folder and choose the pop-up menu command Insert Status Chart.

·Open the Status Chart window and use the Edit menu, or right-click to bring up a pop-up menu, and choose Insert>Chart.

Notes:

·After you successfully insert a new Status Chart, a new tab appears at the bottom of the Status Chart window and a separate component is created under the Status Chart icon in the Instruction Tree window. To rename a Status Chart, right click on its icon in the instruction tree and select Rename. To move between charts, simply click on the tab for the desired chart.

·Sometimes the scroll buttons on the right side of the tab section can cover up a tab. If the tab is not visible, drag on the splitter between the tab area and the scroll buttons in order to make more tabs visible.

Building a Chart

(Back to Top)

In a status chart, you can enter addresses in order to monitor or modify values from your program. Timer and counter values can be displayed as either bits or words. If you display a timer or counter value as a bit, the output status is displayed (output on or off). If you display a timer or counter value as a word, the current value is used.

To build a status chart, follow these steps.

1.Enter the address for each desired value in the Address field.
Most of the memory types listed in PLC Memory Address Ranges are valid, with the exception of Data Constants, Accumulators, and High-Speed Counters.
(To edit an address cell, use the arrow keys or mouse to select the cell that you want to edit.
If you begin typing, the field clears and the new characters are entered.
If you click the mouse or press the "F2" key, the field becomes highlighted and you can use the arrow keys to move the editing cursor to the place that you want to edit.)

2.If the element is a bit (I, Q, or M, for example), the format is set as bit in the Format column. If the element is a byte, word, or double word, select the cell in the Format column and double-click or press the SPACEBAR or ENTER key to cycle through the valid formats until the appropriate one is displayed.

To insert an additional row, use the Edit menu or right-click on a cell in the Status Chart to bring up a pop-up menu, and choose the menu command Insert>Row. The new row is inserted above the current location of the cursor in the Status Chart. You can also place the cursor in any cell of the last row and press the DOWN ARROW key to insert a row at the bottom of the Status Chart.

Tips:

·You can select addresses from the symbol table and copy them into the status chart to build your chart more quickly.

·You can create multiple status charts. This allows you to divide elements into logical groups so that each group can be viewed in a separate chart. This eliminates the need to scroll through a single long, all-inclusive list.

Editing Shortcuts

(Back to Top)

·To insert a new row with the next sequential address and the same data format, select an Address cell and press the ENTER key.

·To cycle through all possible data formats for a given address, select the Data Format cell and press the ENTER key repeatedly. To view all available data formats, click on the drop-down list button.

·To move to the next cell of the chart, press the TAB key.

·To adjust the width of a column, position the mouse pointer on the edge of the column until the cursor changes appearance to a "resizing" cursor, then drag the column edge to the desired location.

·To select an entire row (for cutting or copying), single-click on the row number.

·To insert a new row, select a cell or row and right-click. Choose the pop-up menu command Insert>Row. The row is inserted at the cursor location; subsequent rows are moved down by one.

·To insert a row below the current last row of the chart, place the cursor in any cell of the last row and press the DOWN ARROW key.

·To delete a cell or row, highlight the cell or row and right-click. Choose the pop-up menu command Delete>Selection. If you delete a row, subsequent rows (if any) are moved up by one.

·To select the entire status chart, click once at the upper left corner, above the row numbers.

Data Formats

(Back to Top)

The data format that you assign to a value determines how the value is represented in the status chart.

In the example below, VD0 (and therefore VB0 and V0.0) holds a value of 1.

Tips:

·Bit and binary values are both preceded by the number 2 and the pound (#) symbol. Hexadecimal values are preceded by the number 16 and the pound (#) symbol. Bit values have one digit; binary values have eight digits.

·Signed and unsigned values both use base ten (decimal).

Single Read versus Continuous Chart Status

(Back to Top)

·To obtain a single "snapshot" of values, use the Single Read function: use the menu command Debug>Single Read or use the Single Read toolbar button. (If you have already turned on Chart Status, however, the Single Read function is disabled.)

·To gather status chart information on a continuous basis, turn on Chart Status: use the menu command Debug>Chart Status or use the Chart Status toolbar button.

Writing versus Forcing Values

(Back to Top)

The Write All function allows you to write one or more values to your program to simulate a condition or set of conditions. You can then run your program and use the status chart (and, if desired, Program Status) to monitor what happens. As the program executes, circumstances may cause the values that you modified with the Write All function to be overwritten with new ones.

Note:

If you write a value to an I/O point, you may never see it appear as a current value in the status chart, because on the very next scan the PLC reads the actual field value (as opposed to the value that you wrote in the status chart). It is more effective to use the Force function to assign values to I/O.

The Force function allows you to simulate a logical condition (by forcing V, M, T, or C memory) or a physical condition (by forcing I/O points). When you use the Force function in the status chart to force one or more program values, you are effectively resetting the values with each scan cycle. Although the forced values can be modified by your program in the course of a single scan, when a new scan begins, the forced value is reapplied. Because of the speed with which the PLC executes and the lag time required to convey status information from the PLC to your programming device and display it on the programming device screen, you may not be able to observe any changes to forced values. However, changes are possible during each individual scan.

Warning

When you force a value in your program, the operand is reset to that value with each scan of your program, regardless of input/ output conditions or other program logic that would ordinarily have an effect on the operand value. Forcing can cause your process to operate unpredictably, and unpredictable process operation can cause death or serious injury to personnel, and/ or damage to equipment. The Force function is an aid for debugging your program; never force a value to compensate for problems with your process equipment. Only qualified personnel should use the Force function. Be sure that all personnel who have authority to maintain or debug your process are aware when program values have been forced.


Using the Debug Functions in Status Chart

(Back to Top)

You can access the Debug functions (Single Read, Write All, Force, Unforce, Unforce All, and Read All Forced) from the Debug menu or from the Debug toolbar.

Single Read Use Single Read if you want to obtain a "snapshot," a single update of the program status for all values. By default, Chart Status continually polls the PLC for status updates. When you click on a Status Chart and Chart Status is OFF, the Single Read button is enabled.
Write All After you finish making changes to the New Value column in the Status Chart, you can use Write All to send all the desired changes to the PLC.
Force To force an address to a certain value, you must first stipulate the desired value, either by reading it (if you want to force the current value) or typing it in (if you want to force the address to a new value). Once you use the force feature, the value is re-applied to the address with each scan until you unforce the address. STEP 7-Micro/WIN 32 allows you to force addresses from LAD/ FBD Program Status as well as Chart Status. LAD, FBD, and STL programmers can use the force feature in Chart Status.
Unforce Select an address and use Unforce to remove forcing from that particular address. You can also select (click on) a parameter and then right click it to see the pop-up menu for Force and Unforce functions.
Unforce All If you want to remove forcing from all addresses, use the Unforce All feature. You do not need to select the individual addresses before you apply Unforce All.
Read All Forced When you use the Read All Forced feature, the Current Value column of your Status Chart(s) displays an icon for any addresses that have been explicitly forced, implicitly forced, or implicitly forced in part.

This icon indicates that this address is explicitly forced. The value of this address cannot be changed until the address is unforced.

This icon indicates that this address is implicitly forced. An address is considered implicitly forced if it is part of a larger address that is explicitly forced. For example, if VW0 is forced, then VB0 is implicitly forced (VB0 is the first byte of VW0). An implicitly forced value cannot be unforced on its own. You must unforce the larger address before the value of this address can be changed.

This icon indicates that a portion of this address is partially forced. For example, if VW0 is explicitly forced, then a portion of VW1 is forced (the first byte of VW1 is the second byte of VW0). A partially forced value cannot be unforced by itself. You must unforce the forced address within the value before the value of this address can be changed.

If none of the above three icons appear in the Current Value column next to an address when you issue the Read All Forced command, then that address is not forced.


See Also:

Overview of Debugging and Monitoring Features (GS 7.1)

How to Display Status in the Program Editor (GS 7.2)

How to Execute a Limited Number of Scans (GS 7.4)

How to Download a Program (GS 6.3)

Timestamp Mismatch Error (ensuring that project in programming device matches project in PLC)

Cross Reference and Element Usage (ensuring that program edits do not cause duplicate assignments)

Program Edit in RUN Mode

PLC RUN/ STOP Mode

Writing and Forcing Outputs in STOP Mode