How to Copy Program Segments (GS 8.4)

Use the Edit menu commands and the mouse or standard Microsoft (R) key combinations such as CTRL + A to Select All, CTRL + C to copy, CTRL + X to cut, and CTRL + V to paste.

Tip:

When you paste material, it is inserted in the row or rung above the current location of the cursor.

This topic discusses the following subjects:

Copy a Range of Networks or a POU

Copy Symbol Table or Status Chart Information

Copy Data Block Information

Local Variable Tables

Use Two Instances of STEP 7-Micro/WIN 32 to Copy Between Projects

Use a Single Instance of STEP 7-Micro/WIN 32 to Copy Between Projects

Copy a Range of Networks or a POU

(Back to Top)

ˇYou can copy a range of networks or an entire POU in the LAD, FBD, or STL Program Editor.

ˇYou can paste your selection into a different POU of your program simply by switching tabs at the bottom of the Program Editor window.

ˇYou can also paste your selection into a different project.

Tip: The range of networks that you select for each cut/ copy/ paste operation must be contiguous: they must touch one another. lf you want to copy several networks or sets of networks from different portions of a POU, you have to repeat the cut/ copy and paste operations for each separate selection of networks.

Copy Symbol Table or Status Chart Information

(Back to Top)

ˇYou can copy symbolic name or address information from your Symbol Table and paste it into the Address column of the Status Chart.

ˇYou can copy all columns of information from a Symbol Table or Status Chart and paste it into a Microsoft Excel (R) worksheet, or paste appropriate columns of information from Excel into a Symbol Table or Status Chart.

Copy Data Block Information

(Back to Top)

ˇYou can copy Data Block information and paste it into a text editor.

ˇYou can paste information from a text editor into the Data Block. If the information violates syntax rules, however, the Data Block editor flags it with a red warning X.

Local Variable Tables

(Back to Top)

You cannot block-copy data from one Local Variable Table to another because of the read-only L-memory assignments, which must be unique for each table.

Use Two Instances of STEP 7-Micro/WIN 32 to Copy Between Projects

(Back to Top)

Follow the steps below:

1.Open two separate instances of STEP 7-Micro/WIN 32. (Double-click on the STEP 7-Micro/WIN 32 icon or choose SIMATIC>STEP 7-Micro/WIN 32 from the Start menu. Repeat.)

2.In the first instance of STEP 7-Micro/WIN 32, use File>Open to open the project from which you wish to copy.

3.Select the material and use CTRL + C or Edit>Copy to copy it.

4.In the second instance of STEP 7-Micro/WIN 32, use File>Open to open the project into which you wish to paste the material.

5.Place the cursor at the appropriate location and use CTRL + V or Edit>Paste to paste the material.
Note: Remember to save your work in this project before closing it.

Use a Single Instance of STEP 7-Micro/WIN 32 to Copy Between Projects

(Back to Top)

Follow the steps below:

1.Use File>Open to open the first project, the one from which you wish to copy.

2.Select the material and use CTRL + C or Edit>Copy to copy it.

3.Use File>Close to close the first project.

4.Use File>Open to open the second project, the one into which you wish to paste the material.

5.Place the cursor at the appropriate location and use CTRL + V or Edit>Paste to paste the material.
Note: Remember to save your work in this project before closing it.