LAD/ FBD Editing Tabs (Tools > Options)

These tabs allows you to change the way your Program Editor window appears.

Note:

The settings that you define here only affect how the window looks when you are editing; they do not have to match your settings for Program Status (which are controlled by the LAD/ FBD Status tabs).

You can change the following settings:

Scale (Zoom)

Grid (Cell Width, Cell Height)

Symbol Information Table (Width of Name, Address, IEC Data Type, and Comment Fields)

Symbolic Addressing Display

Scale (Zoom)

Back to Top

Allows you to zoom the Program Editor window to a larger (percentages greater than 100) or smaller (percentages less than 100) display.

Tip:

Hold down the CTRL key and the PLUS (+) or MINUS (-) key from the numeric keypad to quickly increase or decrease the scale percentage (that is, the zoom factor).

Grid (Cell Width, Cell Height)

Back to Top

Allows you to change the ratio of width to height for the cells of the grid.

Units are pixels.

Tips:

ˇYou might want to increase the width measurement if you use long symbol names and do not want them to be truncated.

ˇYou might want to decrease the height measurement in order to view more rows on your screen.

Symbol Information Table (Width of Name, Address, IEC Data Type, and Comment Fields)

Back to Top

Allows you to change the Name, Address, Type (for IEC programs only), and Comment field widths of the Symbol Information Table.

Units are one cell.

Example: If your grid width is 85 pixels per cell, then a name width of 1 is equal to 85 pixels, a name width of 2 is equal to 170 pixels, etc.

Increase this measurement if you do not want long symbol names, addresses, or comments to be truncated.

Note:

The Symbol Information Table feature is controlled from the View menu. A checkmark next to the name means that the feature is turned on and a Symbol Information Table appears beneath every network in your program that contains any symbols.

Symbolic Addressing Display

Back to Top

If you have Symbolic Addressing turned on, you can choose whether to view only symbols or to view both symbols and absolute addresses.

Note:

The Symbolic Addressing feature is controlled from the View menu. A checkmark next to the name means that the feature is turned on. Otherwise, all addresses are displayed as absolute addresses only.

See Also:

LAD/ FBD Program Status Tab (Tools > Options) (to change the way your Program Editor window appears when you are viewing Program Status)